Deprecation Notice: Logger Module

Moogsoft is deprecating support for the Logger Module beginning with Moogsoft Enterprise v7.1.

The Logger module is replaced with Apache Log4j that allows for greater flexibility in logging configuration and the ability to dynamically change components' log levels.

Affected users

Customers installing or upgrading to Moogsoft Enterprise v7.1 or later.

Versions of Moogsoft Enterprise v7.1 or later.

Resolution

Use the Apache Log4j logging utility. See Configure Logging for configuration details. Alternatively refer to the Apache Log4j documentation.