Page tree
Skip to end of metadata
Go to start of metadata

This guide provides instruction on how to upgrade to Moogsoft AIOps ESR 6.3.0. You must upgrade to either v6.0.0, v6.1.0, or v6.2.0 before you upgrade to v6.3.0.

For instructions on how to upgrade from a supported version, refer to the following topics:

For information on types of releases, including Edge Releases, see AIOps Releases.

The steps below summarize the general steps needed in an upgrade from one version of AIOps to the next. For specific details please see the relevant upgrade page.

Backup your existing system

It is always worth backing up an existing deployment so that you can revert changes if needed.

Stop Services and Processes

To swap new upgraded libraries, you must stop any running processes.

Upgrade AIOps

The new version of AIOps is installed via the new RPMs and you must make changes to config files.

Upgrade the Db 

You must upgrade the schema and data within the Db between releases.

Upgrade Apache-Tomcat webapps

Deploy the new Apache-Tomcat servlets.

Restart Services and Processes

You must restart all the processes before running the new version of AIOps.

Verification of upgrade

Run verification scripts to ensure the upgrade was successful.


  • No labels