Moogsoft Enterprise 8.0 Supported Environments

The following operation systems, browsers and third-party software are either supported or are required in order to run Moogsoft Enterprise.

Any operating systems and browsers not listed in the sections below are not officially recommended or supported.

Operating systems

You can run Moogsoft Enterprise on the following versions of Red Hat Enterprise Linux® (RHEL) and CentOS Linux:

OS

Version

CentOS

v7

RHEL

v7

Note

No other Linux distributions are currently supported

Browsers

You can use the following browsers for the Moogsoft Enterprise UI:

Browser

Version

Chrome

Latest

Firefox

Latest

Safari

Latest

Edge

Latest

Note

Due to a known issue in the Safari web browser, you must take additional steps if you've enabled the enhanced Content Security Policy in v8.0 and you want to access the UI with Safari. For more information, see RPM - Upgrade UI components or Tarball - Upgrade UI components depending on your implementation type.

After upgrading macOS to Catalina, the UI is inaccessible in Chrome, Safari and Edge browsers because self-signed certificates are no longer trusted. For workaround instructions see Catalina Browser Certificate Workaround.

Supported Third Party software

Moogsoft Enterprise v8.0 ships with the following third-party applications:

Application

Version

Apache Tomcat®

v9.0.35

Elasticsearch

v6.8.1 (LTS version)

Nginx

v1.14.0 or above

RabbitMQ

v3.7.4

Percona XtraDb Cluster

v5.7.28

Percona XtraBackup

v2.4.20

HA Proxy

v1.5.18-9.el7.x86_64

Other supported application packages include:

Application

Version

Erlang

v20.1.7

JDK

java-11-openjdk-devel >= 1:11.0.5

Apache Tomcat® Native

v1.2.23 or above

You can do a minor upgrade of the JDK (for example, from 11.0.4 to 11.0.5) without having to also update the Moogsoft Enterprise RPM files.

Note

MySQL is supported for upgrading customers only. New Moogsoft Enterprise installations use Percona XtraDB Cluster for database management.

Database support

Database support by version:

AIOps Version

MySQL Community

MySQL Percona

AWS RDS

AWS Aurora1

8.0.x

N/A

5.7.26

N/A

5.7.mysql_aurora.2.04.7

7.3.x

N/A

5.7.26

N/A

5.7.mysql_aurora.2.04.7

7.2.x

5.7.22

N/A

N/A

5.7.mysql_aurora.2.04.7

7.1.x

5.7.22

N/A

N/A

5.7.mysql_aurora.2.04.7

7.0.x

5.7.22

N/A

N/A

5.7.mysql_aurora.2.04.7

6.5.x

5.7.22

N/A

N/A

5.7.mysql_aurora.2.04.7

1 Currently supported for SaaS implementations

Integration support

The following table outlines the vendor supported integrations for the current version of Moogsoft Enterprise alongside the corresponding supported software versions.

Integrations support IPv6 connectivity.

Integration Version

Supported Software / Version

Ansible Tower Integration v1.11

Ansible Tower v3.0, 3.1

Apache Kafka Integration v1.14

Apache Kafka v0.9, 1.1, 2.2

AppDynamics Integration v2.2

AppDynamics v4.0, 4.1

AWS CloudWatch Integration v2.1

aws-java-sdk v1.11

AWS SNS Integration v1.3

Runtime Node.js 8.10, Node.js 10.x, and Node.js 12.x

BMC Remedy Integration v1.9

Remedy v9.1

CA UIM Integration v1.8

CA Nimsoft UIM v8.4

CA Spectrum Integration v2.3

CA Spectrum v10.2

Catchpoint Integration v1.1

Catchpoint v2019

Cherwell Service Management Integration v1.6

Cherwell v9.3

Datadog Polling Integration v1.4

Datadog v2018

Datadog Webhook Integration v1.12

Datadog v5.21

Dynatrace APM Plugin Integration v1.9

Dynatrace v6.5, 7.0

Dynatrace APM Polling Integration v2.4

Dynatrace v7.2.0.1697

Dynatrace Notification Integration v1.6

Dynatrace v1.187.132.20200224-165652

Email Integration v2.6

IMAP, IMAPS, POP3, POP3S

EMC Smarts Integration v1.5

RabbitMQ v3.7.4 and Smarts v9.5

ExtraHop Integration v1.2

ExtraHop v2018

AWS FireLens v1.01

AWS FireLens (New in 8.0)

FluentD Integration v1.11

FluentD v0.12

Grafana Integration v1.2

Grafana v5.2.4

HP NNMi Integration v2.6

HP NNMi v10.30

HP OMi Plugin Integration v1.9

HP OMi v10.1

HP OMi Polling Integration v2.6

HP OMi v10.1

JIRA Service Desk Integration v1.12

JIRA Service Desk v. 4.7.1 and JIRA Cloud Rest API v. 2

JIRA Software Integration v1.12

JIRA Software v. 7, v. 8.7.1 and JIRA Cloud Rest API v. 2

JMS Integration v1.12

ActiveMQ v5.14, JBoss v10, WebLogic v12.0

Moogsoft Express Polling Integration v1.0

Moogsoft Express (new in 8.0)

Moogsoft Express Webhook Integration v1.0

Moogsoft Express (new in 8.0)

Microsoft Azure Integration v1.2

Microsoft Azure Monitor v2018

Microsoft Azure Classic Integration v1.2

Microsoft Azure Classic v2018

Microsoft SCOM Integration v2.7

Microsoft SCOM v2012, 2016 and 2019

Microsoft Teams Integration v1.1

Microsoft Teams v1.2.00.3961

Nagios Integration v2.10

Nagios vXI

New Relic Integration v1.10

New Relic v2016

New Relic Polling Integration v2.1

New Relic v2.3

New Relic Insights Polling Integration v1.1

New Relic v2.3

Node.js Integration v1.10

Node.js v1.6

NodeRED Integration v1.10

Nagios Red v016, 017

OEM Integration v2.3

Oracle Enterprise Manager v12c, 13c

Office 365 Email Integration v1.0

OpsGenie v1.0

Opsgenie's Alerts v2 REST API (new in 8.0)

PagerDuty v1.0

PagerDuty SaaS (new in 8.0)

Pingdom Integration v1.9

Pingdom v2017

Sensu Integration v1.0

Sensu Core v1.8

ServiceNow Integration v4.5

ServiceNow vNew York, Madrid, London, Kingston

SevOne Integration v1.5

SevOne v5.7.2.0

Site24x7 Integration v1.1

Site24x7 June-2019

Slack Integration v1.7

Slack v3.1

SolarWinds Integration v3.3

SolarWinds v. 11.5, v. 12.2, v. 12.3, v. 2019.4

Splunk Integration v2.6

Splunk v. 6.5, v. 6 6, v. 7.0, v. 7.1, v. 7.2, v. 7.3, v. 8.0

Splunk Streaming Integration v1.1

Splunk v. 7.1, v. 7.2, v. 7.3, v. 8.0

Sumo Logic Integration v1.2

Sumo Logic v2018

VMware vCenter Integration v2.4

VMware vCenter v. 6.0, v. 6.5, v. 6.7

VMware vROps Integration v2.4

VMware vROps v6.6, v7.5.0

VMware vSphere Integration v2.5

VMware vSphere v. 6.0, v. 6.5, v. 6.7

VMware vRealize Log Insight Integration v2.5

VMware vRealize Log Insight v4.3

WebSphere MQ Integration v1.13

WebSphere MQ v8

xMatters Integration v2.0

xMatters v5.5

Zabbix Integration v1.0

Zabbix v3.4

Zabbix Polling Integration v3.5

Zabbix v3.2, v4.0, v4.4

Zenoss Integration v2.6

Zenoss v4.2, v6.3.2

Add-ons

Moogsoft Enterprise v8.x supports Moogsoft Add-ons v2.0 and later. See Moogsoft Add-ons.